для версий 1.5.х и 2.0.x