Какой Версией Php Вы Пользуетесь?

Тема в разделе "Предложения и пожелания", создана пользователем FintMax, 20 май 2017.

?

Какой версией PHP вы пользуетесь ?

  1. PHP 5.3

    1 голосов
    1,8%
  2. PHP 5.4

    4 голосов
    7,1%
  3. PHP 5.5

    6 голосов
    10,7%
  4. PHP 5.6

    31 голосов
    55,4%
  5. PHP 7.X

    16 голосов
    28,6%
Можно выбрать сразу несколько вариантов.
  1. Offline

    Jambazeee Пользователь

    Сообщения:
    2
    Симпатии:
    1
    Репутация:
    0
    спасибо
     
  2. Offline

    renep1945 Пользователь

    Сообщения:
    8
    Симпатии:
    5
    Репутация:
    0
    Объясните, шифровка будет изменена, а на уже установленные (модули, шаблоны) повлияет?
     
  3. TopicStarter Overlay
    Offline

    FintMax Команда форума Модератор

    Сообщения:
    1.865
    Симпатии:
    7.957
    Репутация:
    10.173
    на работу модов и шаблонов = не повлияет ни как....
     
  4. Offline

    SeoManjak Пользователь

    Сообщения:
    33
    Симпатии:
    9
    Репутация:
    0
    С установкой проблемы будут какие нибудь?
     
  5. TopicStarter Overlay
    Offline

    FintMax Команда форума Модератор

    Сообщения:
    1.865
    Симпатии:
    7.957
    Репутация:
    10.173
    нет
     
  6. Offline

    фдлщк

    Сообщения:
    495
    Симпатии:
    2.354
    Репутация:
    122
    Да ладно! уже я так думаю в трети движков твои релизы . на демке разработчика видел и не чего работает не глючит и вирусов походу нет !
     
    Gorm нравится это.
  7. Offline

    SHEVA Пользователь

    Сообщения:
    15
    Симпатии:
    3
    Репутация:
    0
    В основном PHP 5.3
     
  8. TopicStarter Overlay
    Offline

    FintMax Команда форума Модератор

    Сообщения:
    1.865
    Симпатии:
    7.957
    Репутация:
    10.173
    это понято - что есть разработчики которые сами используют нуллед продукты..... так всегда было и будет....
     
  9. Offline

    dEEx Пользователь

    Сообщения:
    13
    Симпатии:
    29
    Репутация:
    7
    ИМХО пользоваться древними релизами PHP нецелесообразно, а если хостер тянет с обновлениями - гнать такого в шею.
     
  10. TopicStarter Overlay
    Offline

    FintMax Команда форума Модератор

    Сообщения:
    1.865
    Симпатии:
    7.957
    Репутация:
    10.173
    С 29.09.2017 все наши релизы будут дополнительно шифроваться для PHP 7.1.X

    И + как раньше и было для PHP 5.X

    С нашим коопирайтом....
     
    Последнее редактирование: 11 дек 2017
  11. Offline

    Leonidos0071 Пользователь

    Сообщения:
    13
    Симпатии:
    7
    Репутация:
    0
    Полюбому - 5.6 многие и не парятся
     
    FintMax, raychu и yuliya1989 нравится это.
  12. Offline

    DaSS Пользователь

    Сообщения:
    39
    Симпатии:
    14
    Репутация:
    5
    Пользуюсь PHP 5.6 но в планах перейти на PHP 7.0.
    Кстати, вопрос по поводу Ioncube. Если файл шифровали под версию 5.х будет ли он работать на 7.х?
     
  13. TopicStarter Overlay
    Offline

    FintMax Команда форума Модератор

    Сообщения:
    1.865
    Симпатии:
    7.957
    Репутация:
    10.173
    нет - только если файл зашифрован для php 5.6 то он будет работать на пхп 7.0
    Если нужно для пхп 7.1.х то там шифровка отдельно идёт под него.....
     
  14. Offline

    mpp2007 Пользователь

    Сообщения:
    4
    Симпатии:
    5
    Репутация:
    1
    На "гамнохостингах" рекомендуют 5,6 поскольку с 7+ они еще слабо знакомы.
    Где на хабре читал статью парниши что тестировал как ускорить сайт и переход на пхп 7+ дал ему ощутимый прирост. Не знаю насколько правда сам не проверял, но склонен верить ему.
    Да и если провести аналогию с теми же ЦМС или другими прелестями которыми мы пользуемся то обновление в большинстве случаев идет в лучшую сторону, а устаревшивые версии рано или поздно стают насколько дырявыми что с ними уж и делать нечего.
    Как пример тот же Виндовс ХР, или таже Джумла 1,5 и т.д.
    P.S. Я ни в коем случаи не говорю что чтото плохо илихорошо, это просто мое субьективное мнение (ИМХО - как же я давно нигде не видел этого выражения "ностальгирую")
     
    Suro нравится это.