Возможно Ли Обновление Движка Опенкарт С 1.5.х- 2.х

Тема в разделе "Установка, обновление, настройка", создана пользователем cherem, 22 июн 2017.

?

Возможно ли обновление движка Опенкарт с 1.5х до 2.х (имеется введу без значительных затрат)

  1. Да

    3 голосов
    75,0%
  2. Нет

    1 голосов
    25,0%
  1. TopicStarter Overlay
    Offline

    cherem Пользователь

    Сообщения:
    14
    Симпатии:
    3
    Репутация:
    0
    Всем привет!
    Хотел бы поднять такую тему по поводу возможности обновления движка опенкарт с версий 1.5.х-2.х. Возможно это или нет? Искал по данной теме информацию но ничего конкретного не нашёл мнения разделяются (много писанины но мало по делу):
    'одни говорят, что можно
    'вторые, что нельзя этого сделать
    'третьи говорят, что можно без проблем,но нужны теже самые модули, что и на старом движке используемые в шаблоне для новой версии
    'четвёртые говорят,что есть какие то целевые решения данной задачи, при этом молчат где их взять и как называются
    Просто к примеру я купил ранее шаблон для фотомонтажа версии 1.5.х отдал за это деньги,а шаблон больше не обновляется автором (это я думаю большинство так шаблонов выпускается) и получается что мне теперь нужно оставаться на древней версии, либо как то делать/заказывать новый магазин чтобы хоть как-то скопировать дизайн и функционал. Проблема.
    Или ещё для примера сейчас запускаю магазин на версии 1.5.6 (кстати я практически не работал с опенкарт 2.х) нашёл шаблон который понравился да и модули есть (что пока не скажешь о 2.х, хотя может я здесь не прав), но все равно уже задумался а стоит ли его запускать на этой версии движка или переступить через себя найти новый шаблон 2.х пусть с минусом модулей.

    Так вот подведу небольшой итог:
    1. Возможно ли обновление с 1.5.х до 2.х без потери функционала?
    2. Возможно ли обновление с 1.5.х до 2.х с переносом товара и сохранением шаблона (особенно дизайна) пусть с потерей некоторого функционала или каких то плюшек.?
    3. Есть ли все таки какое то целевое решение для данной проблемы?
    4. Есть ли реальный опыт ( хотелось бы узнать опыт)?
    5. Стоит ли создавать магазин на текущий момент на старых версиях?
     
    lexa1984 нравится это.
  2. Offline

    admin Команда форума Администратор

    Сообщения:
    2.485
    Симпатии:
    93.391
    Репутация:
    175
    Здравствуйте. Да конечно можно. Есть для этого готовый модуль. Но им нужно уметь пользоваться. Перенести можно все, кроме вашего шаблона.
     
  3. TopicStarter Overlay
    Offline

    cherem Пользователь

    Сообщения:
    14
    Симпатии:
    3
    Репутация:
    0
    Подскажите как называется данный модуль?
     
  4. Offline

    superfudof Команда форума

    Сообщения:
    298
    Симпатии:
    187
    Репутация:
    27
    1. Возможно, почти на 95%
    2. С переносом товара - да, дизайн - нет
    3. Есть, у нас на форуме
    4. Есть
    5. Однозначно нет. Факторов почему нет - очень много, легко найти при желании.....
    A-migration......
     
    Stillhard и cherem нравится это.
  5. Offline

    Alexandr777 Пользователь

    Сообщения:
    14
    Симпатии:
    5
    Репутация:
    6
    модуль не всегда корректно делает миграцию базы,
    лично у меня с модулем была куча ошибок, а может руки были кривые.
    Поэтому правил таблицы прямо в MySQL , мигрировал с 1.5.5 на 2.3.0.2 про.
    1. Залил старую базу в новую(предварительно переименовав префикс старой)
    2. Открыл два окна браузера с MySQL.
    3. Сравнивая таблицы старую и новую, sql запросами привел структуру таблиц старой базы,
    к соответствию с новой.
    4. Потом залил нужные мне новые таблицы, данными из старых таблиц.

    На всю миграцию ушло 2 часа.